Installing rails updates.

Ryan Kopf's Blog
Bundler doesn't do a good job of installing a lot of dependencies, which is likely a result of running bundler as a regular user yet needing to install system files as a sudo-wielding administrator.

sudo apt-get install imagemagick libmagickcore-dev libmagickwand-dev
Helps install RMagick.

sudo apt-get install libmysqlclient-dev
Helps install mysql.

sudo apt-get install libsasl2-dev
Helps install mechanize, if I remember correctly.

Please login to post.